AML screening and identity-verification checks failures
Resolved
Jun 18, 2026 at 5:20pm UTC
AML screening and identity-verification checks are working normally again. The third-party rate-limiting behind the delays and failures has cleared, and screenings are completing as expected. The Dotfile API itself was unaffected throughout. We're monitoring to confirm things stay stable; any checks that failed during the incident can now be re-run.
Affected services
Created
Jun 17, 2026 at 9:00am UTC
We're investigating intermittent errors affecting AML screening and identity-verification checks. Some check results from our verification providers (ComplyAdvantage and Onfido) are failing to complete. Affected checks may appear stuck, show an error when opened, or need a manual retry to complete. The Dotfile API itself is unaffected. We're working to restore normal processing and will post updates here.
Affected services