Back to overview
Degraded

Increased processing delay

Feb 12 at 09:47am CET
Affected services
Workers

Resolved
Feb 12 at 12:24pm CET

Incident has been resolved, all delayed processing have now completed.

We will continue to monitor the resolution.

Created
Feb 12 at 09:47am CET

We are currently experiencing increased latency in the processing of certain asynchronous tasks, including risk computation, AML check analysis, online reputation checks, and webhook delivery.
Our team is actively investigating the issue and working to restore normal performance as quickly as possible.
We sincerely apologize for any inconvenience this may cause and appreciate your patience.